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2 Introduction 

Nowadays, universal and unrestricted access to 
documents has become commonplace. In particular, 
PDF documents can be created quickly and easily, 
they look the same everywhere and can be read by 
any device. Whether for the distribution of printed 
material or forms: PDF documents are used 
extensively everywhere to provide various contents. 

Not everyone can benefit from this natural access. 
Especially people with disabilities are often 
confronted with inaccessible PDF documents. An 
example: without appropriate precautions, a blind 
person cannot read a scanned copy, even if it has 
been converted into PDF format. 

With the Act on Equal Opportunities for People with 
Disabilities1 and the BITV 2.02, respectively, public 
bodies are also legally obliged to make digital 
offerings accessible. 

On the following pages we would like to give you 
instructions on how to make your documents 
accessible to more people. Furthermore, your work 
should become more effective and efficient in the 
long term. 

The instructions focus on Adobe InDesign 16 for 
Windows and macOS. Of course, you can use the 
concepts, support and tips presented here regardless 
of which version of InDesign you are using.

  

                                                                 
1 Act on the Equality of People with Disabilities 
(German) 

2 Accessible Information Technology Regulation (as of 
2019) (German)  

http://www.gesetze-im-internet.de/bgg/
http://www.gesetze-im-internet.de/bgg/
http://www.gesetze-im-internet.de/bitv_2_0/
http://www.gesetze-im-internet.de/bitv_2_0/
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3 Basic Principles 

First, we will look at some basic aspects of 
accessibility. You can skip this section and go directly 
to the guide (page 17 onwards) if you are already 
familiar with the basics. The guide is deliberately kept 
clear and simple with examples and pictures. 

3.1 Visual Barriers 

Documents that cause problems for people with 
visual or other disabilities are quickly created without 
appropriate knowledge. However, in this guide we 
are talking primarily about blind people or people 
with visual impairments. The latter is not only the 
most common limitation when working with a 
computer, but also the one with the most varied 
characteristics. What both groups have in common is 
that purely visual information cannot be perceived or 
can only be partially perceived. 

Sighted people distinguish headings from other text 
visually, blind people purely structurally by being 
informed that it is a heading. This is also the case 
with many other text elements, such as paragraphs, 
lists, references, tables and directories. Moreover, 
blind people explore a document sequentially, so the 
reading order must be logical. 

People with a visual impairment can usually only 
perceive information visually to a limited extent. They 
often need support in the form of enlargement or 
increased contrast. 

3.2 Introduction of PDF/UA 

Digital documents can be distributed and spread 
easily, reliably and in original form with the Portable 
Document Format (PDF). Originally, the format was 
designed to preserve the print-like, visual impression 
rather than to preserve the meaning and structure of 
the underlying content. This creates barriers for 
readers, who are dependent on digital accessibility of 
the content  

The document's contents can be structured, 
completed or extended in the PDF by means of 
appropriate labelling. This enables readers who are 
not or not exclusively interested in visual expression 
to fully understand the content and use it 
independently. 

This is done by inserting so-called tags into the 
document. These are standard elements - such as 
headings, lists or paragraphs - which provide an 
indication of the included content or its function. 
These tags can then be used by assistive 
technologies, e. g. screen readers, to output and 
prepare the document content. 

In order to give unrestricted access to PDF 
documents to as many people as possible, the global 
standard ISO 14289-1, better known as PDF/UA, was 
developed in 2012. UA stands for Universal 
Accessibility. 

The standard focuses on the technical aspects and 
does not contain any instructions for the practical 
application of the required measures and 
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possibilities. The support of the standard is supposed 
to ensure that PDF - creating programs can create 
partly accessible or even accessible documents 
without requiring special knowledge of the users. 

The following conditions for PDF/UA compliant 
documents are defined: 

• Significant content must be separated 
from decorative elements (artifacts) and 
must be marked as such. 

• the meaningful elements must be 
arranged in a structure tree and reflect 
the relationships to each other (e. g. 
groupings, etc.). 

• This structure tree should reflect the 
logical reading order of the document. 

• Information must not only be conveyed 
by purely visual characteristics. 
Therefore, pictures and graphics must 
also be provided with alternative textual 
descriptions. 

• Navigation within the document must be 
made possible. 

The PDF/A standard, which many applications 
support, has nothing to do with Accessibility, but 
stands for PDF Archive and is supposed to enable the 
long-term storage of documents. The so-called 
Tagged PDF can be seen as a previous version of PDF, 
which itself is not an ISO standard. 
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4 Structure of InDesign 

The application window of InDesign is divided into 
several areas. Figure 1 shows these areas in macOS. 
The only difference to Windows is that the menu bar 
is below the application bar and not above it. The 
term menu is used in this guide when you need to 
access items on the menu bar. 

For this guide, the menu and control panels are 
particularly relevant. For the images in this guide, the 
InDesign application window was used with 
Workspace Advanced, with an activated application 
frame under macOS.  

You can set both in the Window menu.  For basic 
information on working with InDesign and the 
workspaces, we recommend that you refer to the 
User’s Guide.  

4.1 Context Menu 

For some items, you must open the context menu to 
access the desired setting options. This is done by 
right-clicking on the item. 

 

Figure 1 Structure of the InDesign Application Window 

https://helpx.adobe.com/indesign/user-guide.html/indesign/using/workspace-basics.ug.html
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4.2 Panels 

All control panels can be opened via the Window 
menu (Figure 2). For an efficient workflow we 
recommend to dock the relevant control panels on 
the right side bar. Depending on the set working 
area, there is already a pre-selection of the available 
control panels in the sidebar. You can move, dock 
and undock them from the sidebar at any time by 
holding down the mouse button. So, you can define 
your own personal work area. To create an accessible 
PDF document, you need the panels Paragraph 
Styles, Character Styles and Article. 

4.3 Keyboard Control 

InDesign offers a number of standard key 
combinations for working more efficiently. These are 
listed in this brochure in the appropriate sections. In 
the version used for this manual (16), however, there 
are still accessibility problems when using InDesign, as 
the basic functions cannot be accessed without a 
mouse pointer. For information on possible key 
combinations, see the User’s Guide. 

Press the specified keys simultaneously. The symbol 
of the operating system (Windows: , macOS:  ) 
next to the key combination indicates to which 
operating system it belongs. 

Menu Window → Article 

Menu Window → Styles → Paragraph Styles      

Menu Window → Styles → Character Styles        

 
Figure 2 Open Panels  

https://helpx.adobe.com/de/indesign/user-guide.html/indesign/using/default-keyboard-shortcuts.ug.html


 

 13 

5 Document Structure 

In the introduction it has become clear that when 
creating documents, content should not only be 
prepared in a purely visual way, but a semantic 
meaning should also be assigned to the individual 
elements. The best way this can be done is to use the 
available character and paragraph styles. These are 
templates for headings, paragraphs, lists, etc. 

Mark a text passage and select the desired style in 
the Paragraph Styles or Character Styles panel to 
assign it to the text passage, as shown in Figure 3. 

You can create new styles using the Paragraph 
Styles (Figure 3) and Character Styles panels. You 
can edit existing styles using the Paragraph Style 
Options or the Character Styles Options dialogue 
box. To open this dialogue box, use the context menu 
of a style (Figure 4). 

Panel Paragraph Styles → Select paragraph style → Open Context Menu → Edit Paragraph Style 

Panel Character Styles → Select character style → Open Context Menu → Edit Character Style 

 

Figure 3 Paragraph Styles Panel 

 

Figure 4 Open Paragraph Style Options 
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In addition to visual formatting and language 
settings, the paragraph and character style options 
allow you to specify the mark-up for PDF export 
(Figure 5). This mark-up is called a PDF tag. You have 
the following options: 

• P: Paragraph 

• H1 to H6: Heading from Level 1 to 6 

• Artefact: Artifact, decorative element 
without any content relevance (e. g. decorative 
graphic) 

• [Automatic]: InDesign automatically defines 
the mark-up for PDF export (e. g. for bullets). 

If your document has many paragraph and character 
styles, you can assign the styles to the PDF tags more 
easily and clearly using the Edit All Export Tags 
dialogue box (Figure 7). You can access this via the 
Paragraph Styles or Character Styles control panel 
options (Figure 6).  In this dialogue box, all paragraph 
and character styles and their assigned PDF tags are 
listed in table form and can be adjusted accordingly 
by clicking in the second column. 

Make sure that the assignment of the tags to the 
styles is correct and that you use the styles properly. 
For example, the first heading in the document 
should be assigned to a paragraph style that is 
marked as H1 when exporting to PDF. 

Dialogue Window Paragraph Style Options → Export Tagging → PDF → Tag 

 
Figure 5 Tagging of the Paragraph Style for PDF export 
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Figure 6 Open Dialogue Box "Edit All Export Tags" 

 

Figure 7 Edit All Export Tags 
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6 Guideline 

In this section you will find practical guidelines on 
how to turn your InDesign document into an 
accessible PDF. The guideline covers essential steps 
that you should follow when creating an accessible 
document: Set Document Properties, Word 
Processing and adding Image Descriptions, Setting 
the Reading Order and finally Creating a PDF-
Document and review it. 

Following the guideline does not automatically 
guarantee a PDF document that is accessible in any 
case. This requires further specific checks and 
adjustments, e. g. with Adobe Acrobat DC (Page 17). 

6.1 Document Properties 

The first step for an accessible document is to 
describe it more detailed with general characteristics. 
Add a document title to your document and check 
the document language. 

6.1.1 Document Title 

If your document has a title, it will later appear as the 
window title of your PDF document. People who use 
voice output will have the window title read out and 
therefore know which document it is. In InDesign you 
define the document title via the File Info (Figure 8). 
Enter all meta information about the document here. 
In addition to the title, you can also add further 
information to the document describing it more 
detailed. However, the title is primarily important for 
accessibility. 

Menu File → File Info → Basic → Document Title           

 

Figure 8 Enter Document Title in File Info 
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6.1.2 Document Language

Every PDF document has a basic language. This 
property is particularly relevant for people who use a 
speech output. 

In InDesign, you specify the language using the 
paragraph and character styles format options 
(Figure 9). If your document has sections or individual 

words in different languages, they will require 
different paragraph or character styles to ensure that 
the speech output will reproduce the text correctly. 

The basic language of the entire document is set in 
InDesign only when exporting the PDF file (Page 35).

Dialogue Window Paragraph Style Options/Character Style Options → Advanced Character Formats → 
Language 

 

Figure 9 Define Language for Paragraph Style
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6.2 Word Processing

After these preparations you can get down to the real 
work: creating the content. 

6.2.1 Notes on Design 

All visual characteristics of texts (font size, font 
colour, positioning and number of placeholders, etc.) 
should be organised with paragraph styles and 
character styles. Avoid using spaces and lines to 
position text.   

Suppose you insert several blank lines between two 
lines of text to make room for a graphic that is to 
appear between the two lines. For people who use 
speech output, each blank line inserted in this way is 
read out as "blank“. 

You can check your document for existing spaces and 
lines by using the Normal screen mode, which 
displays the formatting characters (a full stop for a 
space, a paragraph symbol ¶ for a paragraph or 
space). 

Menu View → Screen Mode → Normal 
     

Avoid manual or automatic word division in your 
document. When converting your presentation into a 
PDF document, these are usually not converted 
correctly. In addition, word division makes the 
reading more difficult for people with a visual 
impairment. You can deactivate hyphenation for each 
paragraph style in the paragraph style options 
dialogue box (Figure 10). 

Dialogue box Paragraph Style Options → Hyphenation → Deactivate checkbox Hyphenate 

 

Figure 10 Deactivate Hyphenation 
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6.2.2 Headers and Footers

Recurring page contents, such as the page number or 
the always same footer, should be designed in such a 
way that assistive technologies do not reproduce 
them at the beginning of each page. Therefore, you 
should insert header and footer elements as text 
fields in the master pages3 in InDesign. During PDF 
export, these elements are marked as artifacts and 
thus as intended ignored by assistive technologies. 

Avoid writing content relevant information, e. g. 
contact details, in the footer only, as this information 
is no longer accessible to everyone when converted 
to a PDF document. We recommend that you write 
such information on an extra page. 

6.2.3 Headings 

Headings are the most important elements for 
navigation and orientation for blind people enabling 
them to read content in a structured way. If you use 
the paragraph and character styles correctly, InDesign 
provides good conversion to PDF in this area. For PDF 
export, make sure that the paragraph styles for 
headings are assigned to the correct PDF tags 
(see page 11). 

The nesting of headings in the document must also 
be correct. This means that the first heading in the 
document must be a level 1 heading (H1) and the 
next smaller heading must be a level 2 heading (H2). 
Accordingly, an H1 heading must not be followed 

                                                                 
3 Adobe InDesign: Create Headers and Footers 

directly by a Level 3 (H3) heading if there is no H2 
heading in between. 

Use the heading styles like any other paragraph and 
character style: mark your text and click on the 
paragraph style you want to use for headings in the 
Paragraph Styles panel. 

6.2.4 Paragraphs 

Simple paragraphs of text in your document should 
be formatted as such. The predefined paragraph 
style is usually designated [Basic Paragraph]. As 
described on page 11, you should assign the PDF 
paragraph tag P to it. Depending on how your 
document is to be formatted, different design and 
language variations of this template can then be 
created. 

6.2.5 Bullets and Numberings 

The type of bullet is not reproduced by speech 
output. It is of secondary importance for accessibility, 
as the various types of bullet points are usually 
insignificant in terms of content and are only used for 
decoration. However, you should pay attention to the 
outline structure, i. e. you should structure your 
contents sensibly with the help of the different list 
levels.  

https://helpx.adobe.com/indesign/user-guide.html/indesign/using/numbering-pages-chapters-sections.ug.html#create_headers_and_footers
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In InDesign, different levels can currently only be 
defined for numbering and therefore only numbered 
lists can be nested. Enumerations can be nested 
visually, but semantically they are not marked as 
nested lists. As a result, the content relationship 
between the upper list element and the list elements 
indented below it is lost for assistive technologies. 

Therefore, for complex lists with nesting, use 
numbered lists and define a paragraph style4 for 
each list level, as shown in Figure 11. In addition, all 
list paragraph styles must be selected Automatic as 
PDF tags under Tags export, otherwise they will not 
be correctly marked during export (see page 11). 

Dialogue box Paragraph Styles Options → Bullets and Numbering → Level 

 

Figure 11 Paragraph Styles Options: Define Level for Numbering 

                                                                 
4 Adobe InDesign: Create bulleted or numbered lists 

https://helpx.adobe.com/de/indesign/user-guide.html/en/indesign/using/bullets-numbering.ug.html#create_multi_level_lists
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6.2.6 Links und Cross References 

Links or cross references in the presentation should 
be active shortcuts. In a PDF document such active 
elements can be enabled by left-clicking on them 
while holding down the Control key. They will then 
lead to the referring element. 

External Links 

If your text contains URLs on web pages, you can 
automatically convert them into active hyperlinks 
using the Type menu.  

Menu Type → Hyperlinks and Cross References → 

Convert URLs to Hyperlinks… → Convert All 

Alternatively, you can insert a hyperlink via the 
context menu of a marked text.  

Mark Text → Open Context Menu → Hyperlinks 

→ New Hyperlink… 

With this procedure, the source of the hyperlink, e. g. 
a URL, is no longer displayed in the text. Instead, the 
marked text refers to the stored object. In the 
dialogue box New Hyperlink (Figure 12) you can 
select the type of link: 

• URL of a website 

• File on the computer 

• E-Mail-Address 

• Page within the document (Cross - reference) 

• Text anchor in an InDesign-Document 

Give all hyperlinks in your document an alternative 
text that briefly describes the target of the link. For 
existing or automatically created hyperlinks, you can 
do this using the Edit Hyperlink dialogue box, which 
you open via the link's context menu. From the New 
Hyperlink or Edit Hyperlink dialogue box, go to 
Accessibility in the lower section. In the provided 
text box, enter a meaningful short description of the 
target, as shown in Figure 12. For a URL to a web 
page, this can be the title of the web page. 

Links need an alternative text; otherwise, assistive 
technologies will reproduce them character by 
character. In the case of a very long URL with many 
special characters, the hyperlink is therefore no 
longer accessible. If a generated short URL is used, its 
target is often not apparent from the text anymore. 
Moreover, links must be clearly named to make them 
understandable outside the context and to show 
where they lead. This means, for example, that it is 
not sufficient to label a link with "here”. 

Cross - References 

Cross-references are links to objects within the same 
document. This includes references to tables, figures, 
headings or pages. You can insert cross-references to 
paragraphs in your InDesign document using the 
Type menu (Figure 13). Cross-references to all 
paragraphs, sorted by paragraph style, are possible. 
Just as with external links, make sure to add a 
meaningful alternative text (Figure 14). 

If there are any changes in your document that affect 
the already inserted cross-references, you can update 
them using the Type menu. 
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Figure 12 Add an Alt Text to a Hyperlink 

Menu Type → Hyperlinks and Cross - References → Insert Cross- Reference… 

Menu Type → Hyperlinks and Cross - References → Update Cross - Reference 

 
Figure 13 Insert Cross - Reference 

 
Figure 14 Add an Alt Text to a Cross - Reference 
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6.2.7 Tables of Contents

Tables of Contents have, similar to headings, the 
function of providing an overview, orientation and 
navigation. With InDesign, you can automatically 
create a table of contents which, when converted to 
PDF, enable active list-like navigation. This is based 
on you having created headings with the aid of 
Paragraph Styles, as described in this guide. 

First, navigate to the location in the document where 
you want to place the table of contents.  You can 
insert and always update the table of contents via the 
menu Layout (Figure 15). 

In the Table of Contents dialogue box, make sure 
that the Create PDF Bookmark check box is selected 
(Figure 16). Also, after creating the table of contents, 
you must set alternative texts for the list items, as 
described for hyperlinks (page 22). 

Menu Layout → Table of Contents…  

 

Figure 15 Insert Table of Contents 

 

 

Figure 16 Insert Table of Contents 
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Why are bookmarks so important? 

Bookmarks are an important element for navigating 
and orienting yourself in documents. They resemble 
an interactive Table of Contents. If you view a 

document that contains bookmarks in Acrobat, they 
are displayed in the left-hand area. If you click on a 
bookmark, the focus in the document jumps directly 
to the corresponding content. This is a great help 
especially for long documents. 

 

Figure 17 Bookmark list of a PDF Document in Adobe Acrobat 
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6.2.8 Tables 

If your document is to contain tables, make sure that 
they are structured logically. Pseudo tables, which are 
simulated in InDesign using tabs and spaces, should 
be avoided at all costs. 

When is a table logically structured? 

Even blind people can read and understand tables. In 
the simplest case, they navigate from cell to cell using 
the keyboard and have the contents read out to 
them. Thereby they can recognise which cells are 
heading cells and thus understand the meaning of 
the individual information in the cells - provided that 
the table has the necessary structure and has not 
been brought into table form only visually. Figure 18 
shows how a simple, logically structured table in PDF 
is presented to blind people. 

The table is introduced with <Table>. Rows are 
marked with <TR>, columns with <TD> or with <TH> 
for headings. 

Create a Table 

The Table menu allows you to create a new table. In 
the Create Table window, select the number of 
header rows (Figure 19). These are also marked as 
such when exporting to PDF. 

InDesign only supports tables that can be read 
vertically - tables with headers and data cells below. 
Horizontal tables, i. e. tables with a first column, 
currently cannot be displayed with InDesign in an 
accessible way. This requires a plug-in such as 
MadeToTag from axaio. 

For complex and long tables that do not fit into a text 
box or on a page, you should also set the table 
options to repeat the header row in each text box or 
at least on each page (Figure 20). This ensures that 
the table is still understandable when turning pages. 
However, in the PDF document such a table with 
several header rows is marked as a single table. The 
header row is therefore read out several times. This 
redundancy is not optimal and should be avoided, 
e. g. by using the paid InDesign plug-in MadeToTag. 

 

Figure 18 Logical Structure of a table in PDF in the Adobe-Acrobat Tag-Editor (left) 
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Menu Table → Create Table… → Header Rows 

         

 

Figure 19 Set the number of Header Rows 

Select Table → Menu Table → Table Options → 

Headers and Footers → Repeat Header 

          

 

Figure 20 Repeat Header 

For details on creating tables, refer to the Adobe 
InDesign User's Guide. 

Summary 

A summary is especially important for complex and 
large tables or tables where visual highlighting has 
been done. The summary should make explicit 
reference to the purpose and in particular to the 
highlighted features. It can also explain the structure 
of complex tables in summary form, which can 
increase understanding of the relationships 
presented, especially for people using speech output 
who cannot see the whole picture of the table. You 
can set the summary as alternative text on the table 
after PDF export using Adobe Acrobat DC. 

Note: Complex, multidimensional, nested tables are 
difficult or impossible for blind people to read. If 
possible, complex tables should be divided into 
several simple tables to ensure legibility and 
accessibility. Alternatively, you should include a 
meaningful description of the table in the alternative 
text. 

When choosing colours for the table, you should pay 
particular attention to the needs of people with visual 
impairment or colour vision problems. Therefore, you 
should make sure that there is sufficient contrast 
between the text and the background and that the 
information is understandable without colour.  

https://helpx.adobe.com/de/indesign/user-guide.html/en/indesign/using/creating-tables.ug.html
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6.3 Image Descriptions

Please note that pictures and graphics require a 
meaningful alternative description in order to be 
accessible to blind people. 

6.3.1 Degression: Image Description 

Blind people cannot understand images, graphics or 
diagrams without help. They need an explanation of 
the contents, a so-called alternative description. 

A good image description should have the following 
characteristics: 

• Objectivity (do not introduce your own 
interpretation) 

• Comprehensibility (taking into account the 
target group)  

• Meaningfulness (the description must make 
sense both without and within the context) 

• Clarity and compliance with didactic 
knowledge 

• Effectiveness (keep information complete, but 
as brief and concise as possible) 

The image description should be consistent and 
structured in a strict order according to the type of 
graphic. The internal reading flow of the graphic 
should also be taken into account. When describing 
the image, you should begin with a rough and 
general description and move on to more detailed 
and specific information. 

An image description should enable the non-visual 
reader to obtain all the necessary information 
according to the purpose of the graphic. 

The description should include the following 
information depending on the context and purpose 
of the image: 

• Intention and purpose of the picture  

• Place depicted  

• Objects, buildings, people  

• Emotions, atmosphere  

• What happens in the picture? 

• Colours (however, in diagrams the description 
of visual attributes is only necessary if it 
provides additional information) 

• Only include information that is not accessible 
in any other way, e. g. you should not simply 
repeat the caption or just use explanations 
from the surrounding text. 
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6.3.2 Defining Alt Text for images 

In InDesign you can add an alternative text to an 
image using the Object menu (Figure 21). First, select 
the corresponding image. In the dialogue box Object 
Export Options, you must then enter the alternative 
text under Alt Text, as shown in Figure 22. 

In the Object Export Options dialogue box, you can 
also specify under Tagged PDF, whether the image is 
a decorative graphic. Therefore, select Artefact in the 
selection field Apply Tag (Figure 23). Alternatively, 
you can assign a paragraph style to decorative 
graphics, which will be tagged as Artefact in the 
exported PDF document (see page 11). 

Select Picture → Menu Object → Object Export Options… → Alt Text 

 
Figure 21 Open Object Export Options 

 
Figure 22 Add an Alt Text to a picture 

 
Figure 23 Tag a decorative graphic as Artefact 
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6.3.3 Examples for Alternative Descriptions 

There are different types of pictures, graphics and 
diagrams. If you have no experience with the textual 
description of your graphic content, the following 
examples can help you5. Please note that different 
information may be relevant depending on the 
context of the graphic. 

Decorative Pictures (Decorative Graphics) 

Backgrounds or other graphic decorative elements 
and placeholders in your document, which do not 
contain any information relevant to the content, do 
not require an extra alternative description. As 
described above, they must be tagged as decorative. 
Alternatively, you should consider removing purely 
decorative images from the document. 

 

Figure 24 Example: Decorative Picture 

Pictures with Text 

With advertising, logos, etc. the alternative text 
should contain the text of the graphic. In this 
example the alternative text of Figure 25 should be as 
follows: 

Font graphics: Blindtext weiss 

                                                                 
5 The examples are based on the recommendations of the 

Practical Guide for the Creation of Text-based 
Alternatives for Graphics of the DVBS (The German 

 

Figure 25 Example: Picture with Text 

Content Relevant Pictures 

The picture refers to the content but is not described 
in detail in the text. In this case, the description of the 
image can be very complex. Therefore, as an 
alternative, a link to the detailed picture description 
can be provided, which is located elsewhere (e. g. on 
another page or in an extra document). A possible 
alternative description of Figure 26 is: 

Painting of a woman with long hair sitting in a boat. The 
woman in the picture is wearing a flowing white dress. 
A large elaborately patterned fabric is draped around 
her. In her right hand she holds the anchor chain of the 
boat. Her expression…  

 

Figure 26 Example: Painting 

Association of Blind and Visually Impaired Students and 
Professionals) 

https://weiterbildung.dvbs-online.de/files/ibob-daten/Inhalt/Infothek/Brosch%25C3%25BCren/bf_Gut%2520f%25C3%25BCrs%2520Image%2520-%2520Praxisleitfaden%2520zur%2520Erstellung%2520textbasierter%2520Alternativen%2520f%25C3%25BCr%2520Grafiken.pdf
https://weiterbildung.dvbs-online.de/files/ibob-daten/Inhalt/Infothek/Brosch%25C3%25BCren/bf_Gut%2520f%25C3%25BCrs%2520Image%2520-%2520Praxisleitfaden%2520zur%2520Erstellung%2520textbasierter%2520Alternativen%2520f%25C3%25BCr%2520Grafiken.pdf
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Charts 

For a chart description you should keep to the 
following structure: 

1. Overview: Title, chart type, general content, 
special features such as alignment 

2. Axes: arrangement, labelling, unit, scale 
(range of values, intervals), intersection point 
of the axes 

3. Data, depending on the type of chart, for 
example: number of data series, name and 
arrangement of data, description of rough 
progressions, actual data values (tabular, if 
possible) 

Depending on the purpose of the chart and the 
description, you can also integrate subjective 
statements regarding the chart content into the 
description. However, you must mark these as 
interpretations or your own interpretations. A 
possible alternative text for Figure 27 is: 

Expenses of the last years. Bar chart. Above the columns 
you will find the respective values of the vertical axis.  

The horizontal axis is a time axis with the years 2000 to 
2004. The vertical axis is not shown and has the unit 
millions. 

A data series is shown. The values for the years 2000 and 
2004 are significantly smaller than the values for the 
years 2001 to 2003. 

Data values: 2000: 5,7 Mio., 2001: 22,6 Mio., 2002: 21,9 
Mio., 2003: 22,6 Mio., 2004: 6,7 Mio.  

 

Figure 27 Example: Chart 
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Formulas

We recommend to insert formulas as pictures to 
ensure that they are accessible to everyone. If you 
use pictures in your document that contain 
mathematical representations such as formulas or 
special characters, the alternative text should contain 
a textual version of this formula. 

When describing formulas, ensure that they are clear. 
If your document has many formulas, you should use 
LaTeX or MathML notation in the alternative text to 
make your graphical formula representations 
accessible. You can find more information on this 
topic in the corresponding literature6. 

In Figure 28, the alternative text of the illustrated 
formula in LaTeX notation is:  

                                                                 
6 Wikibooks, Library of free textbooks, non-fiction and 
specialist books: Compendium LaTeX: For 
Mathematicians 

Equation: \ [ a = b + 2 * k * \pi \]  

Or written out in text form: 

Equation: a equals b plus 2 multiplied k multiplied Pi  

 

Figure 28 Example: Formula 

For further examples of alternative descriptions we 
recommend the Practical Guide for the Creation of 
Text-based Alternatives for Graphics of the DVBS.  

https://weiterbildung.dvbs-online.de/files/ibob-daten/Inhalt/Infothek/Brosch%25C3%25BCren/bf_Gut%2520f%25C3%25BCrs%2520Image%2520-%2520Praxisleitfaden%2520zur%2520Erstellung%2520textbasierter%2520Alternativen%2520f%25C3%25BCr%2520Grafiken.pdf
https://weiterbildung.dvbs-online.de/files/ibob-daten/Inhalt/Infothek/Brosch%25C3%25BCren/bf_Gut%2520f%25C3%25BCrs%2520Image%2520-%2520Praxisleitfaden%2520zur%2520Erstellung%2520textbasierter%2520Alternativen%2520f%25C3%25BCr%2520Grafiken.pdf
https://de.wikibooks.org/wiki/LaTeX-Kompendium:_F%25C3%25BCr_Mathematiker#Mathematische_Texte
https://de.wikibooks.org/wiki/LaTeX-Kompendium:_F%25C3%25BCr_Mathematiker#Mathematische_Texte
https://de.wikibooks.org/wiki/LaTeX-Kompendium:_F%25C3%25BCr_Mathematiker#Mathematische_Texte
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6.4 Setting the Reading Order

Before you export your InDesign document as a PDF 
document, you must ensure that the order of 
paragraphs and images is also semantically correct 
and is reproduced correctly by assistive technologies. 
To do so, you should anchor images in the text and 
sort paragraphs using the article control panel.  

6.4.1 Anchoring Pictures 

In print layout, pictures are often not placed directly 
where the text refers to them. For an accessible 
document, it is therefore essential to provide active 
cross-references (page 22) to pictures. Moreover, it is 
also important that the picture is still described in the 
semantic flow of reading close to the referenced. 

In InDesign, you must anchor the graphic frame 
containing the image in a suitable position in the text 
frame. Therefore, select the text frame with the 

selection tool, click on the blue square in the right 
third of the upper edge and drag it to the desired 
position in the text (Figure 29).  The square changes 
into an anchor symbol and a dotted line goes from 
the image to the anchored position in the text (Figure 
30). 

For individual text frames, e. g. captions or texts in 
the marginal column, you can proceed in the same 
way. 

6.4.2 Order of Paragraphs 

To ensure that the created paragraphs and 
embedded images in the exported PDF document are 
actually tagged, you must then group them into 
articles in the article control panel and specify their 
order. 

 

Figure 29 Anchor a picture in a text frame 

 

Figure 30 Anchored Picture in the text 
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First open the Article control panel via the Window 
menu. Add new articles by clicking on the plus 
symbol at the bottom right of the control panel. Make 
sure that Include When Exporting is selected so that 
the articles are tagged in the exported PDF (Figure 
31). Otherwise, the article and the sections it contains 
will not be accessible to users of assistive 
technologies.  

To add an object to an article, for example a text field, 
select it and drag it to the article control panel while 
holding down the left mouse button. Release the 
mouse button here (Figure 32). Alternatively, select 
Add Selection to Articles, the simple plus symbol at 
the bottom of the item panel. The object will then 
appear in the list, indented below the item you 
dragged it.  

In terms of content, pictures that have been 
anchored to a text (page 33) are located in the text 
section and thus in the same article as the text 
section. They do not need to be added to the article. 
This applies to all anchored objects. When you add a 
text box to an article, all linked text boxes are 
automatically added to it. 

The order of the articles and the contained objects in 
the article control panel, from top to bottom, 
corresponds to the reading order in the exported 
PDF document. To change the order, select a list 
entry and drag it to the desired position while holding 
down the left mouse button. 

Make sure that all objects are assigned to an article. 
Otherwise, they are not tagged and not accessible in 
the PDF document. 

Menu Window → Article → New Article → 
Include When Exporting 

 

Figure 31 Create a new Article 

Select Object → Drag it into the Article control 
panel/Button Add Selection to Articles 

 

Figure 32 Add a text section to an Article 
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6.5 Creating a PDF-Document

You have structured your document as simply as 
possible and with the help of Style Sheets? Have you 
provided images with alternative texts and checked 
your links and references for up-to-dateness? Does 
your document have a title? Then you have gotten 
closer to creating your accessible PDF document. 
Now you only have to export your document as PDF. 

For digital publication, a PDF document should be 
created with bookmarks and active links. Therefore, 
you should export an interactive PDF (Figure 33). 

For an accessible PDF document, ensure that the 
following options are selected in the Export to 
Interactive PDF dialogue box, as shown in Figure 34 
and Figure 35: 

• General (Figure 34): 

o Forms and Media: Include All 

o Create tagged PDF  

o Use Structure for Tab Order 

• Advanced (Figure 35): 

o Display Title: Document Title 

o Language: Setting Basic Language of 
the Document 

Menu File → Export… → Format Adobe PDF (Interactive)       

 

Figure 33 Export file as interactive PDF 
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Dialog Window Export to Interactive PDF → General → Options 

 

Figure 34 General Export Options 

Dialog Window Export to Interactive PDF → Advanced → Accessibility Options 

 

Figure 35 Advanced Export Options
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6.6 Checking PDF Documents for 
Accessibility 

There are many ways to review and improve the 
accessibility of PDF documents. Possible tools for 
automatic and manual checking and correction are 
described below. 

It should be noted that an automatic test method 
cannot be used to check the sense of the reading 
sequence, table structure and alternative texts. These 
must therefore be checked manually. The same 
applies to maintaining the minimum contrast 
between text and background, for which 
programmes such as the Colour Contrast Analyser can 
be used. 

The Colour Contrast Analyser can be downloaded via 
 Colour Contrast Analyser    

6.6.1 Checking Accessibility with PAC 3 

The Free PDF Accessibility Checker (PAC 3) is a program 
used to check for compliance with the required 
guidelines of the PDF/UA standard. The program 
itself does not need to be installed but is only 
available for Windows operating systems. It provides 
a detailed inspection report on any problems found 
in the document (Figure 37) and offers a preview of 
what the document would look like with an assistive 
technology. This allows the reading order and nesting 
to be checked. 

The programme can be downloaded from the 
website PDF Accessibility Checker (PAC 3).   

The programme PAC 3 itself cannot automatically 
solve any problems and does not offer any editing 
options. After the test and on the basis of the test 
report, any problems found must be corrected with 
another programme (e. g. Adobe Acrobat DC, axesPDF 
QuickFix). 

 

Figure 36 PAC 3 application window 

 

Figure 37 PAC 3 Report Window 

https://developer.paciellogroup.com/resources/contrastanalyser/
https://www.access-for-all.ch/en/pdf-accessibility-checker.html
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6.6.2 Checking and Improving Accessibility with 
Adobe Acrobat DC

Adobe Acrobat DC is a fee-based programme for 
editing PDF documents. It offers both the possibility 
to check PDF documents for compliance with the 
PDF/UA standard and to correct errors. In contrast to 
PAC 3 and axesPDF QuickFix, it is not only available for 
Windows but also for macOS. 

Many functions of Acrobat DC are accessible via the 
context menu of an element. You can open this menu 
with the right mouse button or by pressing the Shift 
key  and . 

As shown in Figure 38,  the display of the open PDF 
document is located in the centre of the Acrobat DC 
window. Some tools are listed in the right sidebar 
where you can also search for tools. In the left 
sidebar - the navigation area - other views of the 
document are available, including lists of bookmarks 
and tags. Use  to switch the focus between the 
areas. 

Using the Preflight window shown in Figure 39, the 
opened PDF document can be checked for 
compliance with the PDF/UA standards. The window 
can be searched and opened via the input field of the 
tool sidebar. In the Preflight window under the 
Profiles tab, choose PDF/UA and then select Verify 
compliance with PDF/UA-1.  Pressing the Analyze 
button at the bottom of the window starts the 
checking process. If you cannot find the profile on 
your computer, enter PDF/UA in the search field. 

After the checking, the Results tab opens and lists 
any errors (Figure 40). Some errors, such as a missing 
PDF/UA mark or a missing document title, can be 
corrected directly in the Preflight window. Therefore, 
again under the tab Profiles open the view Select 
Single Fixups (spanner symbol). Depending on the 
selected library, various correction options are listed 
here. 

To check and edit the reading order and structure, 
the view of the tags can be found in the Acrobat DC 
sidebar. Here the document structure is visible in a 
nested list of tags, with the actual elements of the 
document marked with a box symbol. By selecting a 
list entry, the corresponding elements are marked in 
the document preview. The reading order and 
nesting can be changed by dragging the individual 
tags. Alternatively, a tag can be cut out and inserted 
after another selected tag. 

Cut: Paste: 

Cut: Paste: 

Note: There is a sidebar called Order, which 
determines the reading order in the Acrobat Reflow 
view. Currently (as of October 2020), however, the 
reading order defined there is independent of the 
order of tags used by assistive technologies such as 
screen readers. Therefore, we want to emphasise 
here that editing the reading order must be done in 
the view Tags in order to make the document 
accessible. 
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Figure 38 Adobe Acrobat DC window 

 

Figure 39 Acrobat DC PDF/UA Inspection in Preflight 
window 

 

Figure 40 Acrobat DC PDF/UA Inspection Results Preflight 
window 
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The view Tags also shows whether the elements in 
the document are correctly tagged, e. g. whether 
headings have been marked as such. Opening the 
context menu of a tag and selecting Properties... 
opens the Object Properties window as shown in 
Figure 41 and Figure 42. Information such as the tag 
type, the language and the alternative text can be 
changed here. For example, if a second level heading 
is marked as <P> instead of <H2>, the tag type can be 
changed in the properties window using a checkbox. 

If your document has no tags, open the Accessibility 
tool and select Tag Document Automatically. 
Acrobat will then automatically tag elements. You can 
then change the tags in the list of tags and add 
alternative texts. Using the Reading Order window 

(Figure 47) of the Accessibility tool, you can also tag 
elements manually, as described later. 

Purely decorative elements in the document, which 
do not offer any added value in terms of content, 
must be marked as such so that they are ignored by 
assistive technologies. To do this, you have to open 
the context menu for the corresponding element in 
the tag window and select Change tag to extra-
textual element... This marks the element as artifact 
and it will not be displayed in the tag window. 

Caution: If you delete an element from the tag tree, 
it is not automatically marked as an artifact, but is 
considered an untagged element in the document, 
which leads to errors when checking for PDF/UA. 

 

Figure 41 Open Acrobat DC Object Properties via the 
context menu of a tag 

 

Figure 42 Acrobat DC Object Properties window
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Complex tables are a major obstacle in creating 
accessible documents. Acrobat DC offers a table 
editor that can be used to add information to the 
table cells. The table editor can be started via the 
context menu of the <Table> tag in the tag window 
(Figure 43). Now the corresponding window is 
opened via the context menu of a cell and by 
selecting the properties of the table cell… (Figure 
44). 

Here, a cell must be marked as a header or data cell. 
For header cells you can also specify whether they 
refer to columns, rows or both (Figure 45). Data cells 
must also be assigned to the corresponding header 
cells, which is also possible in this window (Figure 46). 
For Assigned Heading IDs, a corresponding header 
can be selected and added by clicking the button that 
is labelled with a plus symbol. 

If your table has linked cells that extend over several 
columns or rows, then this must be set explicitly in 
the table cell properties. There are two input fields 
for the number of columns and rows over which the 
cell extends. 

If your table has borders, these may need to be 
manually marked as artifacts. If the corresponding 
path elements are already in the tag view, you can 
proceed as described for the decorative elements 
before. Otherwise, you must manually mark the 
individual path objects as Background/Artifact 
using the Reading Order tool, as shown in Figure 47. 
Therefore, select the path object by dragging the 
mouse pointer over it while pressing the left mouse 
button. Then select the Background/Artifact button 
in the Reading Order window. 

 

Figure 43 Open Table Editor via context menu of 
<Table>-tag 

 

Figure 44 Context menu of a table cell 
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Figure 45 Table Cell Properties window of a Header Cell 

 

Figure 46 Table Cell Properties window of a Data Cell 

 

Figure 47 Label the table border as Artifact using the Reading Order Tool 
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6.6.3 Checking and Improving Accessibility with 
axesPDF QuickFix

With the fee-based programme axesPDF QuickFix, PDF 
documents can be checked for compliance with the 
PDF/UA standard and WCAG 2. It also allows the 
correction of some errors. The programme is 
available for Windows and can be downloaded from 
the website: 

axesPDF QuickFix   

As shown in Figure 48, the logical structure is shown 
in a tree view in the left sidebar. Here you can check 
the reading order and the correct labelling of the 
elements. On the right side of the application 
window, there are various tools for checking and 

editing the document. Via the Checker tab in the 
right sidebar, a PDF/UA standard check of the 
document can be performed with the results 
displayed in a tree view. Click the Refresh button to 
start the check 

The Properties tab of the right sidebar displays the 
properties of the selected item. This is where, e. g. 
the label (structure type) can be changed or an 
alternative text can be set. 

In the Settings tab of the right sidebar, you can 
change such settings as the document language and 
title. 

 

Figure 48 Application window of axesPDF QuickFix 

https://www.axes4.com/axespdf-quickfix-download.html
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AxesPDF QuickFix is particularly suitable for marking 
up complex tables. With the Table tool, which is 
activated via the Viewer tab of the ribbon, cells can 
be assigned to the corresponding header cells by 
dragging them. In the Properties tab of the right 
sidebar, you can also adjust the size of connected 

cells. As shown in Figure 49, the corresponding 
header cells can also be set here. 

With QuickFix, you can re-mark already marked 
elements, but it is not possible to label unmarked 
elements or tag them as artifacts. 

 

Figure 49 axesPDF QuickFix Properties of connected cells 
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6.6.4 Online Validation and Fixing With PAVE

Online tools for checking and improving the 
accessibility of PDF documents have the advantage 
that they can be used regardless of the operating 
system. On the other hand, you must first upload 
your PDF document to a website. It is not always clear 
what the website operator will do with the document, 
for example, whether it will be saved permanently or 
deleted after editing. Before using the online tool, 
you should therefore make sure that uploading your 
document is safe from a data protection perspective. 

PAVE is an online platform that allows you to upload a 
PDF document, have it checked online and at the 
same time manually edit7 any problems that are 
found but not automatically resolved. 

The project can be accessed via the PAVE website.  
   

Using the editing functions, the stored document 
information can be subsequently checked and 
modified, and the document structure and element 
properties can be influenced. 

                                                                 
7 Video Tutorial: Introduction to PAVE v2.0 

Even if no error is displayed in the document 
properties, it is still worth checking them again via the 
Properties tab, as shown in Figure 51. 

In the Reading Order tab (Figure 52) you can check 
and change the document structure and nesting of 
items. Use the pencil icon at the end of a list item to 
edit the selected item. Therefore, the Tagging view, 
as shown in Figure 53, opens. In this view you can, 
i. a., adjust the alternative text and the type of the 
element. For purely decorative elements, you must 
select Not relevant (will not be read out) for the 
element type here. 

Complex changes are not possible with PAVE. 
Significant, extensive changes, such as subsequent 
grouping etc., can be carried out with the fee-based 
Adobe Acrobat DC, for example. 

  

https://pave-pdf.org/?lang=en
https://www.youtube.com/watch?v=5daOdS2yJYM
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Figure 50 PAVE Tasks View 

 

Figure 51 Document Properties in PAVE

 

Figure 52 Reading Order in PAVE 
 

Figure 53 PAVE Tagging View to Edit Tags 
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7 Further Literature 

A useful overview of further steps can be found, for 
example, on the websites of the Aktion Mensch 
Initiative for an Accessible Internet [1]. Adobe 
provides a detailed manual for creating accessible 
PDF documents with InDesign [2] and Acrobat [3]. 

axesPDF QuickFix also has detailed instructions [4]. 
Since Office 2010, Microsoft has integrated an 
accessibility check into the Word, Excel and PowerPoint 
products [5].

[1] Easy For All: PDF-Documents - Readable For All. Part 3 (German) 

[2] Adobe InDesign: Creating accessible PDF-File 

[3] Adobe: Manual for Creating Accessible PDFs (German). 

[4] axesPDF: axesPDF QuickFix – QuickStart-Guide  

[5] Microsoft Office: Improve Accessibility With the Accessibility Checker 

  

http://www.einfach-fuer-alle.de/artikel/pdf_barrierefrei/3/
https://helpx.adobe.com/indesign/using/creating-accessible-pdfs.html
http://www.adobe.com/de/accessibility/products/acrobat/pdfs/BRO_HowTo_PDFs_Barrierefrei_DE_2005_09_abReader7.pdf#pagemode=bookmarks
https://www.axes4.com/files/download/aPQF_Guide_EN_QuickStart_V200604.pdf
https://support.microsoft.com/en-gb/office/improve-accessibility-with-the-accessibility-checker-a16f6de0-2f39-4a2b-8bd8-5ad801426c7f?ctt=5&origin=ha102013555&correlationid=820e335c-8571-4282-97a9-2105015618e9&ui=en-us&rs=en-gb&ad=gb


 

Download the brochure in PDF format at: 

https://tu-dresden.de/agsbs/dokumente 

https://tu-dresden.de/agsbs/dokumente
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