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2 Introduction 
Nowadays, universal and unrestricted access to 
documents has become commonplace. In particular, 
PDF documents can be created quickly and easily, 
they look the same everywhere and can be read by 
any device. Whether for the distribution of printed 
material or forms: PDF documents are used 
extensively everywhere to provide various contents. 

Not everyone can benefit from this natural access. 
Especially people with disabilities are often 
confronted with inaccessible PDF documents. An 
example: without appropriate precautions, a blind 
person cannot read a scanned copy, even if it has 
been converted into PDF format. 

With the Act on Equal Opportunities for People with 
Disabilities1 and the BITV 2.02, respectively, public 

bodies are also legally obliged to make digital 
offerings accessible. 

On the following pages we would like to give you 
instructions on how to make your documents 
accessible to more people. Furthermore, your work 
should become more effective and efficient in the 
long term. 

The instructions focus on PowerPoint 2016 on 
Windows, PowerPoint 2019 on Windows and macOS. A 
guide for PowerPoint 2013 and 2007 can be found in 
previous editions of this brochure3. Of course, you 
can use the concepts, support and tips presented 
here regardless of which version of PowerPoint you 
are using.

  

 
1 Act on the Equality of People with Disabilities 
(German) 

2 Accessible Information Technology Regulation (as of 
2019) (German) 

3 Instructions for the Accessible Design of Documents 

http://www.gesetze-im-internet.de/bgg/
http://www.gesetze-im-internet.de/bgg/
http://www.gesetze-im-internet.de/bitv_2_0/
http://www.gesetze-im-internet.de/bitv_2_0/
https://tu-dresden.de/tu-dresden/chancengleichheit/agsbs/dokumente-1?set_language=en
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3 Basic Principles 
First, we will look at some basic aspects of 
accessibility. You can skip this section and go directly 
to the guide (page 19 ‚onwards) if you are already 
familiar with the basics. The guide is deliberately kept 
clear and simple with examples and pictures. 

3.1 Visual Barriers 

Documents that cause problems for people with 
visual or other disabilities are quickly created without 
appropriate knowledge. However, in this guide we 
are talking primarily about blind people or people 
with visual impairments. The latter is not only the 
most common limitation when working with a 
computer, but also the one with the most varied 
characteristics. What both groups have in common is 
that purely visual information cannot be perceived or 
can only be partially perceived. 

Sighted people distinguish headings from other text 
visually, blind people purely structurally by being 
informed that it is a heading. This is also the case 
with many other text elements, such as paragraphs, 
lists, references, tables and directories. Moreover, 
blind people explore a document sequentially, so the 
reading order must be logical. 

People with a visual impairment can usually only 
perceive information visually to a limited extent. They 
often need support in the form of enlargement or 
increased contrast. 

3.2 Introduction of PDF/UA 

Digital documents can be distributed and spread 
easily, reliably and in original form with the Portable 
Document Format (PDF). Originally, the format was 
designed to preserve the print-like, visual impression 
rather than to preserve the meaning and structure of 
the underlying content. This creates barriers for 
readers, who are dependent on digital accessibility of 
the content. 

The document's contents can be structured, 
completed or extended in the PDF by means of 
appropriate labelling. This enables readers who are 
not or not exclusively interested in visual expression 
to fully understand the content and use it 
independently. 

This is done by inserting so-called tags into the 
document. These are standard elements - such as 
headings, lists or paragraphs - which provide an 
indication of the included content or its function. 
These tags can then be used by assistive 
technologies, e. g., screen readers, to output and 
prepare the document content. 
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In order to give unrestricted access to PDF 
documents to as many people as possible, the global 
standard ISO 14289-1, better known as PDF/UA, was 
developed in 2012. UA stands for Universal 
Accessibility. 

The standard focuses on the technical aspects and 
does not contain any instructions for the practical 
application of the required measures and 
possibilities. The support of the standard is supposed 
to ensure that PDF - creating programs can create 
partly accessible or even accessible documents 
without requiring special knowledge of the users. 

The following conditions for PDF/UA compliant 
documents are defined: 

• Significant content must be separated from 
decorative elements (artifacts) and must be 
marked as such. 

• The meaningful elements must be arranged in 
a structure tree and reflect the relationships to 
each other (e. g. groupings, etc.). 

• This structure tree should reflect the logical 
reading order of the document. 

• Information must not only be conveyed by 
purely visual characteristics. Therefore, 
pictures and graphics must also be provided 
with alternative textual descriptions. 

• Navigation within the document must be 
made possible. 

The PDF/A standard, which many applications 
support, has nothing to do with Accessibility, but 
stands for PDF Archive and is supposed to enable the 
long-term storage of documents. The so-called 
Tagged PDF can be seen as a previous version of PDF, 
which itself is not an ISO standard. 
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4 Structure of PowerPoint 
The PowerPoint application window is divided into six 
areas: the ribbon, two sidebars (Navigation pane and 
Toolbar pane), the slide view, the notes area and the 
status bar. In macOS the menu bar is also relevant. 
The actual structure and naming of the areas in 

Windows can be seen in Figure 1. Figure 2 shows the 
structure in macOS. With the key  the focus can 
be changed between the areas.

 

Figure 1 Structure of the PowerPoint application window on Windows.   

 

Figure 2 Structure of the PowerPoint application window on macOS  
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4.1 Ribbon and Menu Bar 

The ribbon includes the tabs Home, Insert, Design, 
Transitions, Animation, Slide Show, Review, View and 
Help. In Windows, there is also a File tab, which can 
be found in the menu bar in macOS. Additional tabs 
also appear when tables, objects or images are 
selected. Depending on your settings and installed 
Add-ins, additional tabs may be available. 

Below the horizontally listed tabs you will find the 
submenu of the active tab. In Figure 1 and Figure 2, 
the submenu of the active Home tab is shown. The 
menu items are arranged in groups. 

4.2 Status Bar 

The status bar displays information such as the 
current slide and the total number of slides in the 
document. The language can also be changed here. 

4.3 Sidebars 

The PowerPoint window has two side bars. The left 
sidebar, the navigation pane, is used to navigate 
between the slides. Depending on which operating 
system you use, the content of the right sidebar, 
which displays various tools, is called either toolbar 
pane (Windows) or simply pane (macOS). The term 
toolbar is used in these instructions. In contrast to 
the ribbon and the status bar, the side bars must be 
opened actively. 

4.4 Context Menu 

Some PowerPoint functions can be accessed via the 
context menu of a marked object. You can open it 
by right-clicking on a word, picture or table. 
Alternatively, you can select the corresponding object 
and open the context menu by pressing the Shift key 

 and  simultaneously. 

4.5 Keyboard Control 

In general, PowerPoint can also be operated with the 
keyboard only. Therefore, in some places in this 
guideline, possible key combinations are suggested 
to you as an alternative way of controlling PowerPoint. 
The key combinations in Windows differ from those 
in macOS. 

Press the specified keys simultaneously. The symbol 
of the operating system (Windows: , macOS:  ) 
next to the key combination indicates to which 
operating system it belongs. However, these symbols 
primarily show that the described procedure belongs 
to the operating system 
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5 Structure of the Document 
In the introduction it has become clear that when 
creating documents, content should not only be 
prepared in a purely visual way, but a semantic 
meaning should also be assigned to the individual 
elements. With PowerPoint you have to work with 
slide layouts to structure the presentation. These 
are predetermined layout patterns for the 
arrangement of elements on a slide. The actual 
content then only needs to be inserted into the 
placeholders provided. By using slide layouts, you 
make sure that the individual slides are uniformly 
designed, and you can also avoid leaving empty text 
fields etc. on a slide.  

Texts that are inserted in the placeholder for the slide 
title are given a uniform appearance throughout the 

presentation. This means that when using the slide 
layouts, the titles on each slide look the same, are 
always in the same position and also have the 
appropriate meaning, which can be read by users of 
assistive technologies. 

In order to use predefined structures, you should use 
and adapt the standard basic elements of the slides - 
i. e. title and content area. However, they should not 
be replaced by your own elements. 

If you use slide layouts for all slides of your 
presentation, the basis for your accessible and 
consistently designed document is already given. To 
assign a specific layout to a slide, proceed as follows.

Tab Home → Slides → Layout   

 

Figure 3 Change the Slide Layout via the ribbon 
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5.1 Customizing the Slide View 

Every PowerPoint presentation has standard 
templates for slide layouts, which you can adapt 
individually to your visual requirements. For global 
changes to the slide layouts, which are automatically 
adopted by all slides with the same slide layout, you 
should use the slide master (Figure 4). 

In the slide master view, the optical properties of the 
individual elements and the standard content to be 
displayed on all slides can be set. The settings of the 
upper slide master (top slide of the tree in the 
navigation bar) are inherited by the individual slide 
layouts (Figure 5). However, the formatting can also 
be overwritten in the slide layouts4. 

5.1.1 Footers 

Recurring slide contents, such as the page number or 
the always same footer, should be designed in a way 
that assistive technologies do not read them out at 
the beginning of each slide. Footer elements can be 
inserted in PowerPoint in various ways: as text fields 
or as master layout placeholders. 

Option 1: Insert footers as text fields in the slide 
master 

If you insert a text field into the slide master, it will 
appear on every slide and cannot be edited in the 

 
4 For more information about a slide master, see: 
Customize a Slide Master 

normal view. These text fields are not read out again 
on each slide in the normal view. However, during the 
Office internal conversion into a PDF document, they 
are marked as paragraphs and thus read out at the 
beginning of each page of the PDF document, which 
is particularly annoying with complex footers. 
Therefore, this procedure is very well suited for the 
creation of an accessible PowerPoint presentation, 
but not for PDF export. 

Option 2: Insert a footer as master layout 
placeholder 

Alternatively, you can insert master layout 
placeholders, e. g. the page number, in the slide 
master (Figure 6). These can be changed in 
PowerPoint in the normal view and are read out 
again on each slide. When converting to a PDF 
document, however, these elements are marked as 
artifacts, as desired, and thus ignored by assistive 
technologies. If your presentation is only to be 
published as a PDF, we therefore recommend this 
procedure. 

https://support.microsoft.com/en-gb/office/customize-a-slide-master-036d317b-3251-4237-8ddc-22f4668e2b56
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Tab View → Master Views → Slide Master       

 

Figure 4 Open the Slide Master. 

 

Figure 5 Slide Master View  
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Select top Slide Master → Slide Master Tab → Grouping Master Layout → Master Layout →  
Select Placeholders  

 

Figure 6 Insert Placeholders in Master Layout 

Note: In the best case, all elements of the slide 
master, e. g. filled text fields, images and page 
numbers, are ignored by assistive technologies both 
in PowerPoint and in the PDF document. Therefore, 
you should use text fields (option 1) and use Adobe's 
PDFMaker to convert them into a PDF document. This 
will mark all elements of the top slide master as 
artifacts. 

Attention: Do not include relevant information, e. g. 
contact details, in the footer only, as this information 
may be lost when converting to a PDF document. We 
recommend you to write such information 
additionally on an extra slide. 

Close the slide master view to return to normal view 
(Figure 5). 

Tab Slide Master → Grouping Close → Close Master View   

Tab View → Master Views → Slide Master     
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5.2 Views

In addition to the Slide Master, PowerPoint also 
offers other views and tools to help you improve the 
accessibility of your presentation. Using the View 
Tab, you can switch between different views in the 
navigation bar. Apart from the Normal view, which is 
selected by default, the Outline View can also be 
helpful for you (Figure 7). 

The normal view is provided for creating and editing 
your presentation, with the navigation bar showing 
all slides in thumbnail size (Figure 8). 

If you switch to Outline View, instead of the slide 
thumbnails, the navigation bar shows the slide texts 
of your document in outline form. 

Tab View → Presentation Views → Normal     

 

Figure 7 Activate Normal View 

 

Figure 8 PowerPoint Slides in Normal View. 
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Tab View → Grouping Presentation Views → Outline View

Figure 9 Outline View 

Here you can check what is primarily relevant for 
your accessible presentation: the structural 
organisation of your slide contents. The slide title text 
is displayed in bold next to the slide number in the 
navigation bar. 

In Figure 9, the presentation starts on the first slide 
with a slide title followed by a small section of text. 
On the second slide, the title is also shown first, 
followed by an outline list consisting of six elements. 

Knowing about this structure helps blind people to 
recognise the context and meaning of the texts in the 
document – i. e. what sighted people can perceive 
purely visually, for example through the font size or 
highlights. 

Note: In the navigation bar of the outline view, you 
can also make changes to the lists and formatting, 
which will be applied to the slide itself. Unfortunately, 
PowerPoint does not support accessible editing in the 
navigation bar of the outline view (as of October 
2020).
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6 Guideline 
In this section you will find practical guidelines on 
how to turn your PowerPoint document into an 
accessible PDF. The guideline covers essential steps 
that you should follow when creating an accessible 
document: Set Document Properties, Creating a 
Presentation, add Image Description, Creating a 
PDF-Document and review it. 

Following the guideline does not automatically 
guarantee a PDF document that is accessible in any 
case. This requires further specific checks, e. g. with 
Adobe Acrobat DC. Moreover, the quality of your 
documents is highly dependent on the conversion 
tool used – some tools respect the PDF/UA standard 
better than others. However, with this guide you will 
learn the necessary steps to prepare accessible 
documents in PowerPoint and to create presentations 
as accessible as possible.  

General Note: PowerPoint adjusts the display and 
positioning of individual menu items to the size of 
your monitor or the set window size. It is therefore 
possible that the functions described are located in 
other positions than those shown here or that you 
must first actively "open" an additional area before 
you can find the function. 

Currently, no accessible PDF files can be exported 
with PowerPoint for macOS alone. This requires an 
add-in such as the PDFMaker from Adobe. 
Nevertheless, with these instructions you can create 
an almost accessible PowerPoint presentation. 

If there are differences in the process between 
PowerPoint on Windows and PowerPoint on macOS, 
these are described separately. Otherwise, the 
described procedure applies to both operating 
systems. This is also indicated by the corresponding 
symbols:  for Windows and  for macOS. 

This guideline addresses everyone who wants to 
create accessible PDF documents with PowerPoint. 
This also includes people with physical disabilities, 
which is why the alternative texts of the operating 
system symbols often show an alternative way of 
controlling the functions via the keyboard. For 
visually unrestricted readers, the alternative texts can 
be seen when the mouse pointer is placed over a 
graphic or symbol (tooltip).  
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6.1 Document Properties 

The first step for an accessible document is to 
describe it more detailed with general characteristics. 
Add a document title to your presentation and check 
the document language. 

6.1.1 Document Title 

If your document has a title, it will later appear as the 
window title of your PDF document. People who use 
voice output will have the window title read out and 
therefore know which document it is. Setting the 
document title is different on Windows compared to 
macOS. Figure 10 and Figure 11 show you how to set 
the title in Windows, Figure 12 and Figure 13 show 
you the procedure in macOS. 

Tab File → Info → Properties → Title  

 

Figure 10 Position of the File tab on the ribbon in Windows 

 

Figure 11 Set a title in the document properties in Windows 
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Menu bar File → Properties→ Summary  

 

Figure 12 Position of the menu item Properties in the Menu Bar of PowerPoint in macOS 

 

Figure 13 Set a Title in the Document Properties in macOS 
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6.1.2 Document Language 

For each PowerPoint presentation, you can define a 
default language in which it is written. The 
specification of a document language is necessary 
not only for spell checking, but, in addition, also for 
the correct pronunciation of the slide contents of a 
voice output. In PowerPoint you can check and change 
the language of the document via the status bar 
(Figure 14). 

If your document has sections or individual words 
that differ from the default language, you should 
adjust the language setting for these elements, 
otherwise they cannot be correctly reproduced by the 
speech output. This can be done by marking the 
desired text and following the instructions described 
above. 

6.2 Creating a Presentation 

After these preparations you can get down to the real 
work: creating the content. 

6.2.1 Notes on Design 

All visual characteristics of texts (font size, font 
colour, positioning and number of placeholders, etc.) 
should be organised with a slide master. Avoid using 
spaces and lines to position text. 

Suppose you insert several blank lines between two 
lines of text in a text placeholder to make room for a 
graphic that is to appear between the two lines. For 
people who use speech output, each blank line 
inserted in this way is read out as "blank". 

Avoid manual or automatic word division in your 
document. When converting your presentation into a 
PDF document, these are usually not converted 
correctly. 

We recommend you to implement several columns 
using the slide layouts provided instead of inserting 
your own text fields in the slide. When inserting your 
own text fields, you must then check the reading 
order (see 1.1.1 on page 26). 

Tab Review → Grouping Language → Language → Set Proofing Language   

Alternatively: Status Bar→ Language   

 

Figure 14 Language Setting in the Status Bar 
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Tab Home → Grouping Slides → Layout → Two Content   

 

Figure 15 Two Content Layout 

Design your slides by deliberately using different 
layouts defined in the slide master. The placeholders 
provided in the slides should be used correctly to 
ensure that the elements are correctly marked when 
converted to the PDF document: 

• Slide Title 

• Bulleted Lists 

• Links and Cross References 

• Tables 

• Pictures, graphics and diagrams 

• Groupings 

• Videos 

6.2.2 Slide Title 

Slide titles are used to name the contents of a single 
slide briefly and concisely. You should make sure that 
all slides have a unique title, as the titles are used for 
navigation by people who use speech output. 
Furthermore, they form the basis for the outline view 
of the presentation. The slide title should therefore 
be different for each slide.  

Create a slide title always using the placeholder 
provided instead of a simple text box (Figure 10). 
Proceed as described on page 13: Select the slide and 
assign the desired slide layout. You can then insert 
the title in the appropriate placeholder on the slide 
(Figure 16). This will ensure that your presentation 
has a complete table of contents and structure. 
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Figure 16 Insert the Slide Title in the corresponding placeholder 

Tab View → Grouping Presentation Views → Outline View  

 

Figure 17 A Slide without title 

In the Outline View you can check if you have 
applied the slide titles correctly (Figure 17). 

In Figure 17, the titles for the first and second slide 
are applied correctly (in bold, to the right of the slide 
number). On the third slide, however, no text appears 
next to the slide icon (white rectangle), i. e. the 
placeholder for the title has not been filled with 
content.  
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6.2.3 Hiding Elements on Slides

In some cases, you may not want the slide title to be 
visible, e. g. if only one graphic is to be displayed on 
the slide. Then you should at least create an invisible 
title. Therefore, you can hide the title by using the 
toolbar Selection (Figure 18). 

In the toolbar, select the eye icon to the right of the 
relevant content identifier to change its visibility.
      

In this way, the title is displayed correctly in the 
outline view, but is no longer visible on the slide itself. 

Attention: The hidden elements are also removed 
from the exported PDF document. 

Tab Home → Grouping Drawing→ Arrange → Selection Pane… → Toolbar Selection      

 

Figure 18 Open the Selection Pane 
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6.2.4 Setting the Reading Order of the Elements

Blind readers access the content of a document in a 
linearised way, i. e. one element after the other is 
read aloud by the speech output. If elements are 
arranged next to each other, the logical reading 
order of the slide is not obvious. Here the reading 
sequence must be specified. Especially with 
additionally inserted elements that have been added 
to the selected slide layout, the reading sequence is 
usually incorrect. PowerPoint does not determine the 
reading order of the elements by the position of the 
elements on the slide, but by the time they were 
inserted. For example, if you insert a text box into an 
existing slide layout, it will automatically be the last 

element in the reading order, regardless of whether it 
was placed at the top or bottom of the slide. 
Therefore, after you have specified all the contents of 
a slide, you should check the reading order. 

Just like the showing and hiding of slide elements, the 
reading order can be checked and adjusted in the 
toolbar Selection (Figure 19). 

Attention: The lower element in the selection area is 
read out first, the upper element last! In the example 
in Figure 19, the title would be read out first, followed 
by the content and image. 

Tab Home → Grouping Drawing→ Arrange → Selection Pane… → Toolbar Selection 

Toolbar Selection → Selecting Element → drag to the desired position while holding down the left 
mouse button   

Moving up selection:          

Moving down selection:          

 

Figure 19 Toolbar Selection 
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6.2.5 Bullets 

You should always insert your slide contents into the 
provided placeholders (Figure 20) of the selected 
slide layout. For lists you should use the Bullets tools 
of PowerPoint (Figure 21). 

Although the type of bullets is not reproduced by 
speech output, it is of secondary importance for 
accessibility, as the various types of bullet are usually 
insignificant in terms of content and only serve 
decorative purposes. However, you should pay 
attention to the outline structure, i. e. you should 
sensibly structure your content with the help of the 

different List Levels. In this context, it is important 
that the indents characterising the list levels are not 
created by spaces but are increased and decreased 
by using the Tab key or the tools offered by 
PowerPoint. Therefore, place the mouse pointer in the 
respective bullet point and select the button 
Increase List Level for right indentation, or the 
button Decrease List Level for left indentation 
(Figure 22). 

Thus, indentations are not only visually displayed, but 
also semantically marked accordingly. In this case, 
the PDF export usually also includes a correct 
conversion. 

Tab Home → Grouping Paragraph → Bullets  

 

Figure 20 Content Placeholder 

 

Figure 21 Bullets  

Tab Home → Grouping Paragraph → Increase List Level or Decrease List Level   

Tab Home → Grouping Paragraph → Indent More or Indent Less   

 

Figure 22 Increase/Decrease List Level 
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6.2.6 Links and Cross References

Links or cross references in the presentation should 
be active shortcuts. When your slides are played as a 
slide show, such elements can be activated with a 
mouse click and lead to the linking element (e. g. 
another slide, a web page). 

With the AutoFormat function activated by default in 
PowerPoint, entered external links, e. g. 
www.tu-dresden.de, are automatically recognised as 
such and converted into active links. The address of 
the link corresponds to the displayed text. This can 
be adjusted in the context menu under Edit link. 
Alternatively, a link can also be inserted via the 
context menu. Therefore, place the mouse pointer at 
the desired insertion position of the link or mark the 
text to be linked and open the context menu. Via the 
entry Link or Hyperlink, you open the dialogue 

Insert Link as shown in Figure 23 and Figure 24. Set 
the alternative text of the hyperlink, e.g., the title of 
the website, via ScreenTip…. 

The Insert Link dialogue window allows you to insert 
the following types of links:  

• Link to files or websites    

• References to new documents   

• References to E-Mail-Addresses     

• References to a slide/heading of the current 
document (requires a good document 
structure and the use of slide layouts) 
   

Mark object → Open Context Menu → Link      

 

Figure 23 Dialogue "Insert Link" in PowerPoint on 
Windows 

 

Figure 24 Dialogue window "Insert Link" on macOS 

http://www.tudresden.de/
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6.2.7 Tables 

If a slide should contain tables, it is particularly 
important to ensure that these are logically 
structured. 

When is a table logically structured? 

Even blind people can read and understand tables. In 
the simplest case, they navigate from cell to cell using 
the keyboard and have the contents read out to 
them. Thereby they can recognise which cells are 
heading cells and thus understand the meaning of 
the individual information in the cells - provided that 
the table has the necessary structure and has not 
been brought into table form only visually. Figure 25 
shows how a simple, logically structured table in PDF 
is presented to blind people. 

The table is introduced with <Table>. Rows are 
marked with <TR>, columns with <TD> or with <TH> 
for headings. 

Pseudo tables, which are simulated in PowerPoint 
using tabs and spaces, should be avoided at all costs. 
To create well-structured tables in PowerPoint, the 
table tool should always be used. 

Step 1: Create a Table 

There are several ways to insert tables: 

1)

2)

Use the Insert table symbol in the 
placeholder for the slide content and set the 
desired number of columns and rows in the 
Insert table dialogue (Figure 26).
Insert the table via the ribbon. Therefore, 
select the content placeholder in the slide in 
which the table is to be inserted (Figure 27).

Using the second way, there are four ways to insert a 
table in PowerPoint: 

• Insert Table via Matrix

• Insert table entering number of rows and
columns and other options for the width of the
table

• Draw Table

• Excel Spreadsheet

Avoid Excel-Spreadsheets. These are not supported by 
the export option presented here and require 
manual marking and revision afterwards. 

Figure 25 Logical Structure of a table in PDF in the Adobe-Acrobat Tag-Editor (left) 
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Step 2: Mark Headings

Regardless of which option you use to create the 
table, the second step is to mark the header row or 
the first column of the table as a heading. Proceed as 
follows: 

When the Header Row option is enabled in the Table 
Style Options grouping of the Table Design tab 
(Figure 28), the header row is visually distinguished 

from the other cells. Since PowerPoint 2019, the table 
header has also been structurally marked during PDF 
export. The same applies if the option First column 
with the first table column is selected. With older 
versions of PowerPoint, the header cells are 
unfortunately not correctly marked during PDF 
export and must then be marked manually with a 
PDF editing program such as Adobe Acrobat DC. 

Tab Insert → Grouping Table → Table → select the desired number of columns and rows with the 
mouse pointer or the arrow keys  

 

Figure 26 Insert a table via Placeholder for the Slide 
Content 

 

Figure 27 Insert a table via Matrix 

Select table → Tab Table Design → Grouping Table Style Options → select Header Row/First Column 
   

 

Figure 28 Table Design 
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Step 3: Summary

A summary is especially important for complex and 
large tables or tables where visual highlighting has 
been done. The summary should make explicit 
reference to the purpose and in particular to the 
highlighted features. It can also explain the structure 
of complex tables in summary form, which can 
increase understanding of the relationships 
presented, especially for people with speech output 
who cannot see the whole picture of the table. The 
summary can be set as an alternative text to the 
table (Figure 29). 

Note: Complex, multidimensional, nested tables are 
difficult or impossible for blind people to read. If 
possible, complex tables should be divided into 
several simple tables to ensure legibility and 
accessibility. Alternatively, you should include a 
meaningful description of the table in the alternative 
text. 

When choosing colours for the table, you should pay 
particular attention to the needs of people with visual 
impairment or colour vision problems. Therefore, you 
should make sure that there is sufficient contrast 
between the text and the background, and that the 
information is understandable without colour. 

Select table → open Context Menu → Edit Alt Text…→ Toolbar Alt Text → Input field for Alt Text   

 

Figure 29 Add an Alt Text to a table 
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6.2.8 Images, Graphics and Charts

In this section we explain what you need to consider 
when working with pictures and graphics 
(illustrations) in order to integrate different types of 
graphics using the possibilities available in 
PowerPoint. At this point, please note that you must 
always give an alternative text to an illustration. The 
following section Image Description (page 36) deals 
with what you should bear in mind when working 
with alternative texts.  

Charts 

To insert a diagram into PowerPoint, you can either 
select the diagram icon in an empty content 
placeholder on the slide or you can insert the 
diagram using the Insert tab (Figure 30). 

After selecting the desired chart type, a new window 
appears in which you can enter your data in a table. 
When the chart is selected, the two tabs Chart 
Design and Format are now available (Figure 31).  
Using the tab Chart Design, you can choose one of 
the predefined Chart Styles (Figure 32).

When choosing colours, you should also pay special 
attention to the needs of people with visual 
impairment or colour vision problems. This means 
that when making your choice, you should ensure 
that there is sufficient contrast between the data 
series and that the information is understandable 
even without colour. 

To manually adjust the individual colours, you can 
select an element of the relevant data series and 
define the filling effect as shown in Figure 33. 

You should also give your chart a meaningful title. 

Note: As with a normal graphic, enter a meaningful 
alternative text for the chart. (page 42). 

Tab Insert → Grouping Illustrations → Chart   

 

Figure 30 Insert a chart 
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Figure 31 Chart Design and edit chart data 

Tab Chart Design → Grouping Chart Styles   

 

Figure 32 Tab Chart Design with Chart Styles 

Select Element → Tab Home → Grouping Drawing → Shape Fill   

 

Figure 33 Change colours of chart elements 
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Free forms and Groupings 

Other illustrations should be created in the same way 
as charts using PowerPoint tools, rather than 
inserting individual images. Compared to purely 
visual images, more semantic information is available 
and can be reproduced by assistive technology. 

If you want to draw your own illustrations within your 
presentation using free forms, you should assign an 
alternative text to each element that does not contain 
text, as shown in Figure 34. For shapes that contain 
text, the text is automatically taken as the alternative 
text of the shape after conversion to a PDF 
document. You should make sure that the reading 
order is correct (page 26). 

Furthermore, you should combine the individual 
forms into a grouping. This allows you to define 

figures that consist of several shapes, e. g. a bicycle 
created from two circles and several rectangles. The 
advantage of grouping is not only that elements 
defined as belonging together can be moved 
together, but also that only one alternative text needs 
to be created for the whole group when the 
document is viewed in PowerPoint. For conversion 
into a PDF document, however, it is advisable to 
provide an alternative text for the individual 
elements, as the grouping can be lost during export. 

To group several elements, you must first select each 
element individually while holding down the Shift 
key. Then you can group the selected elements using 
the context menu. Then add an alternative text to 
your grouping that describes the structure of the 
grouped elements in a meaningful way. This can be 
done, as with other graphical elements, via the 
toolbar Alt Text (page 38). 

Figure 34 Alt Text of a Free Form 
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Context Menu → Grouping → Grouping

Figure 35 Grouping shapes 

Note: If necessary, groupings can be split up again 
into their individual elements using the context menu 
item Ungroup. Elements of a group can still be easily 
selected within the group to edit and move them 
without ungrouping. 

Note: In PowerPoint, groupings are not exported to 
PDF format and the alternative text is also lost. 
Therefore, after PDF export, Groupings must be 
manually reunited and the alternative text must be 
inserted again. 

Tip: For PDF export, you can save the entire shape 
group on the slide using the context menu Save as 
graphic..., then replace the shape group with a single 
image and set the alternative text accordingly. 

In this case the alternative text is also available in the 
exported PDF. 

SmartArts 

For SmartArts, also enter a meaningful alternative 
text in which you provide a textual explanation of the 
displayed information. Up to the current version of 
PowerPoint, the alternative text of SmartArts is not 
always retained when exporting to a PDF document 
(as of October 2020). We therefore recommend that, 
before exporting, you convert the SmartArt into 
shapes using the context menu and proceed as 
described for free forms. 

Select SmartArt → context menu → Convert to
Shapes 



36 

Videos 

Videos, like images and charts, can be inserted using 
the corresponding Insert Video button of an empty 
content placeholder. Alternatively, a video or sound 
file can also be placed using the ribbon (Figure 36 
and Figure 37). 

Videos should also have an alternative text describing 
what happens in the video and summarising the 
intention. This can be entered again via the Alt Text 
toolbar. 

Dynamic content cannot be reproduced in PDF files. 
A visible image description must be provided for the 
video content, which is also accessible to sighted 
readers who do not have direct access to the 
alternative description. 

In addition to the image description, the link to the 
source should be visibly indicated - if it is an online 
medium. This ensures that the video content can also 
be accessed from a static PDF document or a printout 
on paper. You can also link to this address (Page 27). 
The easiest way to do this is to enter the web address 
for the video in an additional text field, which you can 
then place anywhere on the slide and arrange in the 
reading order after the video. 

Accessible videos have to include both subtitles, for 
people with impaired hearing or deafness, and an 
audio transcript for people with visual impairment 
or blindness. In addition to the spoken word, the 
audio transcript has to describe both the spoken and 
non-verbal content of the video. Subtitles should also 
take into account relevant background noise. 

Tab Insert → Grouping Media → Video → Online Video… or Video on my PC…   

 

Figure 36 Insert a Video in Windows 
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Tab Insert → Grouping Media → Video →Video Browser… or Video from File… or Online Film …   

 

Figure 37 Insert a Video in macOS 

Tab Insert → Grouping Illustrations → Shapes → Group Basic Shapes → Text Box   

 

Figure 38 Insert a Text Box 

Animations

PowerPoint provides you with a wide range of options 
for animating your presentation, for example, to 
show or hide individual objects or entire slides. 
However, they cannot be converted into a PDF 
document or on paper. 

For this reason, you should create an animation-free 
presentation for PDF export and emphasise your 

content in other ways which everyone can benefit 
from. However, if you don't want to do without 
animations, they should at least become visible only 
through user input (e. g. keystroke) to ensure manual 
control of the content. In this guideline, animations 
are not dealt with in any more detail.  
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6.3 Image Description

Please note that pictures and graphics require a 
meaningful alternative description in order to be 
accessible to blind people. 

6.3.1 Degression: Image Description 

Blind people cannot understand images, graphics or 
diagrams without help. They need an explanation of 
the contents, a so-called alternative description. 

A good image description should have the following 
characteristics: 

• Objectivity (do not introduce your own 
interpretation) 

• Comprehensibility (taking into account the 
target group)  

• Meaningfulness (the description must make 
sense both without and within the context) 

• Clarity and compliance with didactic 
knowledge 

• Effectiveness (keep information complete, but 
as brief and concise as possible) 

The image description should be consistent and 
structured in a strict order according to the type of 
graphic. The internal reading flow of the graphic 
should also be taken into account. When describing 
the image, you should begin with a rough and 
general description and move on to more detailed 
and specific information. 

An image description should enable the non-visual 
reader to obtain all the necessary information 
according to the purpose of the graphic. 

The description should include the following 
information depending on the context and purpose 
of the image: 

• Intention and purpose of the picture  

• Place depicted 

• Objects, buildings, people  

• Emotions, atmosphere  

• What happens in the picture? 

• Colours (however, in diagrams the description 
of visual attributes is only necessary if it 
provides additional information) 

Only include information that is not accessible in 
any other way, e. g. you should not simply repeat 
the caption. 

6.3.2 Defining Alt Text for images 

Since PowerPoint 2019 there is the toolbar Alt Text, 
which allows you to add an alternative description to 
an image. It can be opened via the context menu 
(Figure 39). 

Decorative graphics without any relevant information 
can be marked as decorative at this point. In this case 
they will be ignored by assistive technologies. 

Toolbar Alt Text → Mark as decorative   
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Since PowerPoint 2019 the possibility of generating an 
alternative text for images has also been available. 
Currently, however, these alternative texts are not 
very meaningful, so it is not recommended to rely on 
this function). 

In older versions of PowerPoint, you can enter an 
alternative text under Size and Properties in the 
Format Picture Toolbar (Figure 40).

Select Image → Open Context Menu → Edit Alt Text…   

 

Figure 39 Insert Alt Text  
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Select Picture → Open Context Menu → Format Picture … → Size & Properties → Alt Text  

 

Figure 40 Insert Alt Text in PowerPoint 2016 and older
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6.3.3 Examples for Alternative Descriptions 

There are different types of pictures, graphics and diagrams. 
If you have no experience with the textual description of 
your graphic content, the following examples can help you5. 
Please note that different information may be relevant 
depending on the context of the graphic. 

Decorative Pictures (Decorative Graphics) 

Backgrounds or other graphic decorative elements 
and placeholders in your document, which do not 
contain any information relevant to the content, do 
not require an extra alternative description. They 
must be marked as decorative via the Alt Text 
Toolbar. In older versions of Word, where this 
function does not exist, decorative graphics must be 
manually marked as artifacts in the final PDF 
document. Alternatively, you should consider 
removing purely decorative images from the 
document. 

 

Figure 41 Example: Decorative Picture 

 
5 The examples are based on the recommendations of the  

Practical Guide for the Creation of Text-based 
Alternatives for Graphics (German) of the DVBS (The 

Pictures with Text 

With advertising, logos, etc. the alternative text 
should contain the text of the graphic. In the example 
in Figure 43  the alternative text should be as follows: 

Font graphics: Blindtext weiss 

 

Figure 42 Example: Picture with Text 

Content Relevant Pictures 

The image refers to the content but is not described 
in detail in the text. In this case, under certain 
circumstances the description of the image can be 
very complex. Therefore, as an alternative, a link to 
the detailed image description can be provided, 
which is located elsewhere (e. g. on another slide or 
in an extra document). A possible alternative 
description of Figure 43 is: 

Painting of a woman with long hair sitting in a boat. The 
woman in the picture is wearing a flowing white dress. A 
large elaborately patterned fabric is draped around her. 
In her right hand she holds the anchor chain of the boat. 
Her expression … 

German Association of Blind and Visually Impaired 
Students and Professionals) 

https://weiterbildung.dvbs-online.de/files/ibob-daten/Inhalt/Infothek/Brosch%25C3%25BCren/bf_Gut%2520f%25C3%25BCrs%2520Image%2520-%2520Praxisleitfaden%2520zur%2520Erstellung%2520textbasierter%2520Alternativen%2520f%25C3%25BCr%2520Grafiken.pdf
https://weiterbildung.dvbs-online.de/files/ibob-daten/Inhalt/Infothek/Brosch%25C3%25BCren/bf_Gut%2520f%25C3%25BCrs%2520Image%2520-%2520Praxisleitfaden%2520zur%2520Erstellung%2520textbasierter%2520Alternativen%2520f%25C3%25BCr%2520Grafiken.pdf
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Figure 43 Example: Painting 

Charts 

For a chart description you should keep to the 
following structure: 

1) Overview: Title, chart type, general content, 
special features such as alignment 

2) Axes: arrangement, labelling, unit, scale (range 
of values, intervals), intersection point of the 
axes 

3) Data, depending on the type of chart, for 
example: number of data series, name and 
arrangement of data, description of rough 
progressions, actual data values (tabular, if 
possible) 

Depending on the purpose of the chart and the 
description, you can also integrate subjective 
statements into the chart description, regarding the 
chart content. However, you must mark these as 
interpretations or your own interpretations. 

A possible alternative text for Figure 44 is: 

Expenses of the last years. Bar chart. Above the columns 
you will find the respective values of the vertical axis.  

The horizontal axis is a time axis with the years 2000 to 
2004. The vertical axis is not shown and has the unit 
millions. 

A data series is shown. The values for the years 2000 and 
2004 are significantly smaller than the values for the 
years 2001 to 2003. 

Data values: 2000: 5,7 Mio., 2001: 22,6 Mio., 2002: 21,9 
Mio., 2003: 22,6 Mio., 2004: 6,7 Mio. 

 

Figure 44 Example: Chart 
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Formulas

If you use pictures in your document that contain 
mathematical representations such as formulas or 
special characters, the alternative text should contain 
a textual version of this formula.  

If possible, do not insert formulas via Word, as they 
are often not accessible. You can save the formula as 
an image using a screenshot, in Windows for example 
with the Snipping Tool6, in macOS with the app 
Screenshot7 . You can insert this image into the 
document and set an alternative text. 

When describing formulas, ensure that they are clear. 
If your document has many formulas, you should use 
LaTeX or MathML notation in the alternative text to 
make your graphical formula representations 
accessible. You can find more information on this 
topic in the corresponding literature8. 

The alternative text of the illustrated formula in 
LaTeX notation in Figure 45 is 

Equation: \ [ a = b + 2 * k * \pi \] 

Or written out in text form: 

Equation: a equals b plus 2 k times Pi 

 

Figure 45 Example: Formula 

For further examples of alternative descriptions we 
recommend the Practical Guide for the Creation of 
Text-based Alternatives for Graphics (German) of the 
DVBS.

 

 
6 Taking a Screenshot by Means of the Snipping Tools 
on Windows 
7 Taking Screenshots or Screen Recording on the Mac 

8 Wikibooks, Library of free textbooks, non-fiction and 
specialist books: Compendium LaTeX: For 
Mathematicians 

https://weiterbildung.dvbs-online.de/files/ibob-daten/Inhalt/Infothek/Brosch%25C3%25BCren/bf_Gut%2520f%25C3%25BCrs%2520Image%2520-%2520Praxisleitfaden%2520zur%2520Erstellung%2520textbasierter%2520Alternativen%2520f%25C3%25BCr%2520Grafiken.pdf
https://weiterbildung.dvbs-online.de/files/ibob-daten/Inhalt/Infothek/Brosch%25C3%25BCren/bf_Gut%2520f%25C3%25BCrs%2520Image%2520-%2520Praxisleitfaden%2520zur%2520Erstellung%2520textbasierter%2520Alternativen%2520f%25C3%25BCr%2520Grafiken.pdf
https://support.microsoft.com/en-gb/help/13776/windows-10-use-snipping-tool-to-capture-screenshots
https://support.microsoft.com/en-gb/help/13776/windows-10-use-snipping-tool-to-capture-screenshots
https://support.apple.com/en-gb/guide/mac-help/mh26782/mac
http://bit.ly/1SulTnl
http://bit.ly/1SulTnl
http://bit.ly/1SulTnl
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5.4 Accessibility Check with Office

Before you export a Word document to PDF and then 
have to make elaborate improvements to the PDF 
document, it is worthwhile having an internal Office 
check for accessibility problems first. 

Note: With the steps described here you create an 
accessible Word document. However, problems 
resolved in Office will not prevent problems from 
appearing in the exported PDF document because, as 
explained at the beginning of the chapter, not all 
export tools comply with all guidelines of the PDF/UA 
standard. 

Since Office 2010 an integrated accessibility check is 
available in all Office applications. Since PowerPoint 
2019 a new menu item has been available in the 
Review tab of the ribbon. With older versions the 
check is started via the file information. 

The Accessibility toolbar opens in the right sidebar 
(Figure 48). At the top of the toolbar there is a list of 
errors and warnings grouped by type. Clicking on an 
error or warning immediately selects the affected 
element so that you do not have to search for. 

Below the list there is an area that provides more 
detailed information about the selected error. It also 
contains reasons for the need to correct the error 
and information on how to correct it. 

Correct the errors and warnings, and then check the 
document again. Only export the presentation when 
there are no more errors left. 

In the example shown in Figure 48, it is noted, among 
other things, that the chart created in PowerPoint 
does not include any alternative text.

Tab Review → Grouping Accessibility → Check Accessibility   

 

Figure 46 Check Accessibility  
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Tab File → Info → Button Check for Issues → Check Accessibility  

 

Figure 47 Accessibility Check in PowerPoint 2016 and older versions 

 

Figure 48 Results of the Accessibility Check 
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6.4 Creating a PDF-Document 

You have structured your document as simply as 
possible and with the help of Style Sheets? Have you 
provided images with alternative texts and checked 
your links and references for up-to-dateness? Does 
your document have a title? Then you have gotten 
closer to creating your accessible PDF document. 
Now you only have to export your document as PDF. 

There are of course many more ways to create PDFs, 
as there are numerous programs and extensions for 
conversion. Not all of these programs will maintain 
the logical structure of your document. The option 
recommended here will adopt a large part of the 
preparations correctly.  

It is not advisable to use a so-called PDF printer, as it 
does not export the logical structure. 

6.4.1 Exporting as PDF with Office 

Microsoft Office provides a standard module for 
exporting to PDF. If it had to be manually installed in 
earlier versions, it is already pre-installed in Office 
versions > 2010. 

In the Publish as PDF or XPS dialogue window 
(Figure 50), the file name, type and location for final 
publication can be specified. You can also open this 
dialogue with the button  as an alternative to the 

steps just described. Then, however, you must still 
select PDF as the file type. 

Use the Options button in the dialogue to specify 
settings for PDF export. Set the following options as 
shown in Figure 51:  

• Option Document properties: adds 
information to the PDF, such as the document 
title.  

• Option Document structure tags for 
accessibility: all structure information is 
added to the PDF. 

• Disable Bitmap text [...]: This would cause 
text contents to be saved as image 
information, making them unreadable for 
non-visual users. 

Confirm by clicking the OK button and save the 
document with the Publish button. 

Attention: In macOS no accessible PDF documents 
can be created from PowerPoint. This requires 
add-ins, such as the PDFMaker from Adobe. 

Note: No bookmarks are exported from PowerPoint 
to PDF. The PDFMaker add-in from Adobe however 
supports this feature.
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Tab File → Export → Create PDF/XPS-Document   

 

Figure 49 Export as PDF-Document 

 

Figure 50 Dialogue Window to Save 
 

Figure 51 Dialogue window: Options to Save as PDF-
Document 
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Why are bookmarks so important? 

Bookmarks are an important element for navigating 
and orienting yourself in documents. When you view 
a document that contains bookmarks, they are 

displayed in the left sidebar. If you click on a 
bookmark, the focus in the document jumps directly 
to the corresponding content. This is a helpful 
feature, especially for long documents. 

 

Figure 52 Bookmark List of a PDF-Document in Adobe Acrobat  
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6.5 Checking PDF Documents for 
Accessibility 

There are many ways to review and improve the 
accessibility of PDF documents. Possible tools for 
automatic and manual checking and correction are 
described below. 

It should be noted that an automatic test method 
cannot be used to check the sense of the reading 
sequence, table structure and alternative texts. These 
must therefore be checked manually. The same 
applies to maintaining the minimum contrast 
between text and background, for which 
programmes such as the Colour Contrast Analyser can 
be used. 

The Colour Contrast Analyser can be downloaded 
via Colour Contrast Analyser.   

6.5.1 Checking Accessibility with PAC 3 

The Free PDF Accessibility Checker (PAC 3) is a program 
used to check for compliance with the required 
guidelines of the PDF/UA standard. The program 
itself does not need to be installed, but is only 
available for Windows operating systems. It provides 
a detailed inspection report on any problems found 
in the document (Figure 54) and offers a preview of 
what the document would look like with an assistive 
technology. This allows the reading order and nesting 
to be checked. 

The programme can be downloaded from the 
website PDF Accessibility Checker (PAC 3).  

The programme PAC 3 itself cannot automatically 
solve any problems and does not offer any editing 
options. After the test and on the basis of the test 
report, any problems found must be corrected with 
another programme (e. g. Adobe Acrobat DC, axesPDF 
QuickFix). 

 
Figure 53 PAC 3 application window 

 

Figure 54 PAC 3 Detailed inspection report of PAC 3 with 
preview 

https://developer.paciellogroup.com/resources/contrastanalyser/
https://www.access-for-all.ch/en/pdf-accessibility-checker.html
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6.5.2 Checking and Improving Accessibility with 
Adobe Acrobat DC  

Adobe Acrobat DC is a fee-based programme for 
editing PDF documents. It offers both the possibility 
to check PDF documents for compliance with the 
PDF/UA standard and to correct errors. In contrast to 
PAC 3 and axesPDF QuickFix, it is not only available for 
Windows but also for macOS.    

Many functions of Acrobat DC are accessible via the 
context menu of an element. You can open this menu 
with the right mouse button or by pressing the Shift 
key  and . 

As shown in Figure 55, the display of the open PDF 
document is located in the centre of the Acrobat DC 
window. Some tools are listed in the right sidebar 
where you can also search for tools. In the left 
sidebar - the navigation area - other views of the 
document are available, including lists of bookmarks 
and tags. Use  to switch the focus between the 
areas. 

Using the Preflight window shown in Figure 56, the 
opened PDF document can be checked for 
compliance with the PDF/UA standards. The window 
can be searched and opened via the input field of the 
tool sidebar. In the Preflight window under the 
Profiles tab, choose PDF/UA and then select Verify 
compliance with PDF/UA-1.  Pressing the Analyze 
button at the bottom of the window starts the 
checking process. If you cannot find the profile on 
your computer, enter PDF/UA in the search field. 

After the checking, the Results tab opens and lists 
any errors (Figure 57). Some errors, such as a missing 
PDF/UA mark or a missing document title, can be 
corrected directly in the Preflight window. Therefore, 
again under the tab Profiles open the view Select 
Single Fixups (spanner symbol). Depending on the 
selected library, various correction options are listed 
here. 

To check and edit the reading order and structure, 
the view of the tags can be found in the Acrobat DC 
sidebar. Here the document structure is visible in a 
nested list of tags, with the actual elements of the 
document marked with a box symbol. By selecting a 
list entry, the corresponding elements are marked in 
the document preview. The reading order and 
nesting can be changed by dragging the individual 
tags. Alternatively, a tag can be cut out and inserted 
after another selected tag. 

Cut:   Paste:    

Cut:   Paste:    

Attention: In Adobe Acrobat DC there is a sidebar 
called Order. Use this sidebar to set the reading order 
in the Acrobat reflow view. Currently (as of October 
2020), however, the reading order specified there is 
independent of the tag order used by assistive 
technologies such as screen readers. Therefore, we 
would like to emphasise here that editing the reading 
order must be done in the view Tags, so that the 
document is understandable for all users. 
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Figure 55 Adobe Acrobat DC window

 

Figure 56 Acrobat DC PDF/UA Inspection in Preflight 
window 

 

Figure 57 Acrobat DC PDF/UA Inspection Results Preflight 
window 
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The view Tags also shows whether the elements in 
the document are correctly tagged, e. g. whether 
headings have been marked as such. Opening the 
context menu of a tag and selecting Properties... 
opens the Object Properties window as shown in 
Figure 58 and Figure 59. Information such as the tag 
type, the language and the alternative text can be 
changed here. For example, if a second level heading 
is marked as <P> instead of <H2>, the tag type can 
be changed in the properties window using a 
checkbox. 

If your document has no tags, open the Accessibility 
tool and select Tag Document Automatically. 
Acrobat will then automatically tag elements. You can 
then change the tags in the list of tags and add 
alternative texts. Using the Reading Order window 

(Figure 64) of the Accessibility tool, you can also tag 
elements manually, as described later. 

Purely decorative elements in the document, which 
do not offer any added value in terms of content, 
must be marked as such so that they are ignored by 
assistive technologies. To do this, you have to open 
the context menu for the corresponding element in 
the tag window and select Change tag to extra-
textual element... This marks the element as artifact 
and it will not be displayed in the tag window. 

Caution: If you delete an element from the tag tree, 
it is not automatically marked as an artifact, but is 
considered an untagged element in the document, 
which leads to errors when checking for PDF/UA.

 

Figure 58 Open Acrobat DC Object Properties via the 
context menu of a tag 

 

Figure 59 Acrobat DC Object Properties window 
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Complex tables are a major obstacle in creating 
accessible documents. Acrobat DC offers a table 
editor that can be used to add information to the 
table cells. The table editor can be started via the 
context menu of the <Table> tag in the tag window 
(Figure 60). Now the corresponding window is 
opened via the context menu of a cell and by 
selecting the Table Cell Properties… (Figure 61).  

Here, a cell must be marked as a header or data cell. 
For header cells you can also specify whether they 
refer to columns, rows or both (Figure 62). Data cells 
must also be assigned to the corresponding header 
cells, which is also possible in this window (Figure 63). 
For Assigned Header Cell IDs, a corresponding 
header can be selected and added by clicking the 
button that is labelled with a plus symbol. 

If your table has linked cells that extend over several 
columns or rows, then this must be set explicitly in 
the table cell properties. There are two input fields 
for the number of columns and rows over which the 
cell extends. 

If your table has borders, these may need to be 
manually marked as artifacts. If the corresponding 
path elements are already in the tag view, you can 
proceed as described for the decorative elements 
before. Otherwise, you must manually mark the 
individual path objects as Background/Artifact 
using the Reading Order tool, as shown in Figure 63. 
Therefore, select the path object by dragging the 
mouse pointer over it while pressing the left mouse 
button. Then select the Background/Artifact button 
in the Reading Order window. 

 

Figure 60 Open Table Editor via context menu of <Table>-
tag 

 

Figure 61 Context menu of a table cell 
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Figure 62 Table Cell Properties window of a Header 
Cell 

 

Figure 63 Table Cell Properties window of a Data Cell 

 

Figure 64 Label the table border as Artifact using the Reading Order Tool.
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6.5.3 Checking and Improving Accessibility with 
axesPDF QuickFix 

With the fee-based programme axesPDF QuickFix, PDF 
documents can be checked for compliance with the 
PDF/UA standard and WCAG 2. It also allows the 
correction of some errors. The programme is 
available for Windows and can be downloaded from 
the website: 

axesPDF QuickFix  

As shown in Figure 65, the logical structure is shown 
in a tree view in the left sidebar. Here you can check 
the reading order and the correct labelling of the 
elements. On the right side of the application 
window, there are various tools for checking and 
editing the document. Via the Checker tab in the 
right sidebar, a PDF/UA standard check of the 
document can be performed with the results 
displayed in a tree view. Click the Refresh button to 
start the check. 

The Properties tab of the right sidebar displays the 
properties of the selected item. This is where, e. g. 
the label (structure type) can be changed or an 
alternative text can be set. 

 

Figure 65 Application window of axesPDF QuickFix 

https://www.axes4.com/axespdf-quickfix-download.html
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In the Settings tab of the right sidebar, you can 
change such settings as the document language and 
title. 

AxesPDF QuickFix is particularly suitable for marking 
up complex tables. With the Table tool, which is 
activated via the Viewer tab of the ribbon, cells can 
be assigned to the corresponding header cells by 
dragging them. In the Properties tab of the right 

sidebar you can also adjust the size of connected 
cells. As shown in Figure 66, the corresponding 
header cells can also be set here. 

With QuickFix, you can re-mark already marked 
elements, but it is not possible to label unmarked 
elements or tag them as artifacts. 

 

Figure 66 axesPDF QuickFix Properties of connected cells 
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6.6 Online Validation and Fixing With 
PAVE 

Online tools for checking and improving the 
accessibility of PDF documents have the advantage 
that they can be used regardless of the operating 
system. On the other hand, you must first upload 
your PDF document to a website. It is not always clear 
what the website operator will do with the document, 
for example, whether it will be saved permanently or 
deleted after editing. Before using the online tool, 
you should therefore make sure that uploading your 
document is safe from a data protection perspective. 

PAVE is an online platform that allows you to upload a 
PDF document, have it checked online and at the 
same time manually edit9 any problems that are 
found but not automatically resolved. 
The project can be accessed via the PAVE website.

   

Using the editing functions, the stored document 
information can be subsequently checked and 
modified and the document structure and element 
properties can be influenced. 

 
9 Video Tutorial: Introduction to PAVE v2.0 

Even if no error is displayed in the document 
properties, it is still worth checking them again via the 
Properties tab, as shown in Figure 68 . 

In the Reading Order tab (Figure 69) you can check 
and change the document structure and nesting of 
items. Use the pencil icon at the end of a list item to 
edit the selected item. Therefore, the Tagging view, 
as shown in Figure 70, opens. In this view you can, 
i. a., adjust the alternative text and the type of the 
element. For purely decorative elements, you must 
select Not relevant (will not be read out) for the 
element type here. 

Complex changes are not possible with PAVE. 
Significant, extensive changes, such as subsequent 
grouping etc., can be carried out with the fee-based 
Adobe Acrobat DC, for example. 

https://pave-pdf.org/?lang=en
https://pave-pdf.org/?lang=en
https://www.youtube.com/watch?v=5daOdS2yJYM
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Figure 67 PAVE Tasks View 

 

Figure 68 Document Properties in PAVE 

 

Figure 69 Reading Order in PAVE 
 

Figure 70 PAVE Tagging View to Edit Tags 
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7 Further Literature 
A useful overview of further steps can be found, for 
example, on the websites of the Aktion Mensch 
Initiative for an Accessible Internet [1]. Adobe 
provides a detailed manual for creating accessible 

PDF documents with Acrobat [2]. axesPDF QuickFix 
also has detailed instructions [3]. Since Office 2010, 
Microsoft has integrated an accessibility check into 
the Word, Excel and PowerPoint products [4].

[1] Easy For All: PDF-Documents - Readable For All. Part 3 (German) 

[2] Adobe: Manual for Creating Accessible PDF

[3] axesPDF: axesPDF QuickFix – QuickStart-Guide 

[4] Microsoft Office: Improve Accessibility With the Accessibility Checker 

  

http://www.einfach-fuer-alle.de/artikel/pdf_barrierefrei/3/
https://www.adobe.com/de/accessibility/products/acrobat/pdfs/acrobat-x-pdf-accessibility-best-practices.pdf
https://www.axes4.com/files/download/aPQF_Guide_EN_QuickStart_V200604.pdf
https://support.microsoft.com/en-gb/office/improve-accessibility-with-the-accessibility-checker-a16f6de0-2f39-4a2b-8bd8-5ad801426c7f?ctt=5&origin=ha102013555&correlationid=820e335c-8571-4282-97a9-2105015618e9&ui=en-us&rs=en-gb&ad=gb
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Download the brochure in PDF format at: 

https://tu-dresden.de/agsbs/dokumente 

https://tu-dresden.de/agsbs/dokumente
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